简体   繁体   中英

Should I Include Words Model, Service, Mediator in Event Names

If an event is dispatched by a service should I include the word 'service' in the event class name? For Example TwitterServiceEvent . The same applies to Models and Mediators.

In robotlegs book "Actionscript Developers Guide to Robotlegs" they are not using it that way:

_remoteService.addEventListener(TwitterEvent.OVER_CAPACITY, dispatchOverCapacity);

But if you want it and it helps you, you can have it, why not. I use signals, but when I name signals, I name them the same as the command is named with different suffix:

ConfigureViewSignal
ConfigureViewCommand 

Also, did you check out AS3 Signals and SignalCommandMap for robotlegs? https://github.com/robertpenner/as3-signals https://github.com/robertpenner/robotlegs-extensions-SignalCommandMap

The technical post webpages of this site follow the CC BY-SA 4.0 protocol. If you need to reprint, please indicate the site URL or the original address.Any question please contact:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2024 STACKOOM.COM