繁体   English   中英

安装升级的XCode版本后出现问题

Issues after installing upgraded XCode version

提示:本站收集StackOverFlow近2千万问答,支持中英文搜索,鼠标放在语句上弹窗显示对应的参考中文或英文, 本站还提供   中文繁体   英文版本   中英对照 版本,有任何建议请联系yoyou2525@163.com。

我最近安装了XCode DP 4.5 - 只是为了试用iOS 6.我用它打开了一个项目。

当我再次使用XCode 4.2.1重新打开时,我开始在这里提到故事板数据丢失问题

我在4.5 DP中没有遇到这个问题,但后来我不想继续使用XCode 45 DP。 我不确定它是否有效用它构建我的应用程序。 此外,它向我显示“iPhoneOS 5.0 sdk not found warning”,这是我在项目中设置的基本sdk。

我该怎么做才能摆脱这个问题? 可以继续使用4.5 DP吗? 如果没有,我怎样才能安全地回到4.2.1? 项目中是否有任何解决方法可以重新获得我的故事板? 我也备份了故事板,但是一旦我将它导入我的项目(在4.2.1内) - 它就会抱怨它无法打开它。 所以我怀疑这是由于45 DP和4.2.1共享的设置。

请帮忙...

2 个回复

下载适用于iOS 6的Golden Master并将其用于您的开发。 由于GM版本App可能会被编译以便与它一起分发,Xcode 4.2.1将变得过时。

默认情况下,故事板设置为与当前版本的Xcode和先前版本兼容。 您可以通过修改storyboard的文件检查器中弹出的开发版本,选择使它们与更旧的版本兼容。

1 升级后出现问题

您好,升级扑通后,我有这个问题... 我以前没有这个问题。 任何想法 ? 谢谢 ...

2019-07-26 12:56:31 1 24   flutter
3 升级Rails版本时出现问题

我是Ruby on Rails的新手。 我的问题是,我正在尝试将Rails版本从1.2.3升级到2.3.4。 我改变了.rhtml文件.html.erb根据轨道版本2.3.4。 我根据rails版本更改了环境和boot.rb设置,但是当我尝试运行该应用程序时,我发现模板错误丢失了,它正 ...

6 升级到xcode 10后出现问题-找不到文件

我将Xcode升级到版本10,然后发现无法构建。 但是在Xcode 9中工作正常。我还看到此链接: 升级到Xcode 10后的问题:找不到构建输入文件,但解决方案不起作用。 我收到此错误: ...

8 Xcode #include文件从3.2.6升级到4.5.1后出现问题

自将C ++项目从Xcode 3.2.6升级到Xcode 4.5.1以来,我遇到了最奇怪的#include文件问题:无法找到我的静态链接库之一的#include头文件。 我没有整个项目的其他未定义符号错误。 #include位于前缀标头“ MacClient_Prefix.pch”中(我 ...

9 升级弹性搜索后结果出现问题

我将Elasticsearch从2.2升级到7.1,并且维护了这两个实例,并通过进行相同的搜索查询来尝试比较新版本和旧版本的结果。 注意:我尚未更改映射,设置或查询逻辑 我的结果几乎相同,但得分略有不同。 是预期的吗? 尽管文档,映射,设置和查询逻辑是相同的? ...

10 升级后Grails和FilterPane出现问题

我刚刚从grails 1.2.0升级到1.3.7,并升级到了最新版本的FilterPane插件。 现在我有一个错误,以前可以。 在我的list.gsp中,我曾经/曾经 ... 然后在Controller中将filter操作更新为 如在插件页面中。 现在我得 ...

暂无
暂无

声明:本站的技术帖子网页,遵循CC BY-SA 4.0协议,如果您需要转载,请注明本站网址或者原文地址。任何问题请咨询:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2021 STACKOOM.COM