简体   繁体   中英

Error in WNDR3800 running Gargoyle 1.11 network config VLAN ID setup

I have a Netgear WNDR3800 running Gargoyle version 1.11. In the network config file I am trying to set up a VLAN ID of 2 which is required for my ISP (they provided a router that needs a reboot every month and DHCP can't reserve more than 32 IP addresses). This needs to be done in the /etc/config/network file.

I've coded comms software before but this network thing is a whole new kettle of fish.

The config is as follows and it is not correct - my fixed lan connections are not connecting with this:

config interface 'loopback'                                                     
        option ifname 'lo'                                                      
        option proto 'static'                                                   
        option ipaddr '127.0.0.1'                                               
        option netmask '255.0.0.0'                                              

config globals 'globals'                                                        
        option ula_prefix 'fdee:bdcf:b059::/48'                                 

config interface 'lan'                                                          
        option type 'bridge'                                                    
        option ifname 'eth0.1'                                                  
        option proto 'static'                                                   
        option ipaddr '192.168.1.1'                                             
        option netmask '255.255.255.0'                                          
        option ip6assign '60'                                                   
        option dns '192.168.1.1'                                                

config interface 'wan'                                                          
        option ifname 'eth1.2'                                                  
        option ipv6 '0'                                                         
        option proto 'pppoe'                                                    
        option keepalive '3 5'                                                  
        option username 'USERNAME'                                   
        option password 'PASSWORD'                                            
        option mtu '1480'                                                       

config interface 'wan6'                                                         
        option ifname 'eth1.2'                                                  
        option proto 'dhcpv6'                                                   

config switch                                                                   
        option name 'switch0'                                                   
        option reset '1'                                                        
        option enable_vlan '1'                                                  
        option blinkrate '2'                                                    

config switch_vlan                                                              
        option device 'switch0'                                                 
        option vlan '1'                                                         
        option ports '0 1 2 3'                                                  

config switch_vlan                                                              
        option device 'switch0'                                                 
        option vlan '2'                                                         
        option ports '5t'        

config switch_port                                                              
        option device 'switch0'                                                 
        option port '1'                                                         
        option led '6'                                                          

config switch_port                                                              
        option device 'switch0'                                                 
        option port '2'                                                         
        option led '9'                                                          

config switch_port                                                              
        option device 'switch0'                                                 
        option port '5'                                                         
        option led '2'                                                          

The original config had one "config switch vlan" section which included all ports '0 1 2 3 5t' I'm not 100% sure but believe the 'config interface lan' had ifname - 'eth0' defined, no plan. The 'config interface wan' was set to eth1 (again not 100% sure, might have been eth0 as well.

I thought I would have to separate the LAN and WAN by going them each their own vlan but as it is now, the hardwired connections don't work.

I tried changing the lan interface to 'eth0.2' and then the fixed ports work. But I think there might be contention somehow as the wifi dropped out at some stage.

Would any network guru be able to help?

Thanks Ron

I have it working, what was missing is the CPU port on vlan '1' - this meant any fixed connections weren't working but WIFI connected hosts were.

The fix:

config switch_vlan                                                              
    option device 'switch0'                                                 
    option vlan '1'                                                         
    option ports '0 1 2 3 5t' 

And despite me answering my own question, I still don't consider myself a network guru.

Regards Ron

The technical post webpages of this site follow the CC BY-SA 4.0 protocol. If you need to reprint, please indicate the site URL or the original address.Any question please contact:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2024 STACKOOM.COM