简体   繁体   中英

Why should we use Convert? - HackerRank, 30 Days of Code

I was solving 30 days of code's second day.

    int i = 4;
    double d = 4.0;
    string s = "HackerRank ";

    int a = 12;
    double b = 4.0;
    string c = "is the best place to learn and practice coding!";
    
    
    a = Convert.ToInt32(Console.ReadLine()); ???????????
    b = Convert.ToDouble(Console.ReadLine());
    c = Console.ReadLine();
    

    Console.WriteLine(i + a);
    Console.WriteLine((d + b).ToString("F1"));
    Console.WriteLine(s + c);

I did not understand why do we use convert. Why am i converting this variables to console.readline??

Question:

Objective Today, we're discussing data types. Check out the Tutorial tab for learning materials and an instructional video!

Task Complete the code in the editor below. The variables, , and are already declared and initialized for you. You must:

Declare variables: one of type int, one of type double, and one of type String. Read lines of input from stdin (according to the sequence given in the Input Format section below) and initialize your variables. Use the operator to perform the following operations: Print the sum of plus your int variable on a new line. Print the sum of plus your double variable to a scale of one decimal place on a new line. Concatenate with the string you read as input and print the result on a new line. Note: If you are using a language that doesn't support using for string concatenation (eg: C), you can just print one variable immediately following the other on the same line. The string provided in your editor must be printed first, immediately followed by the string you read as input.

Input Format

The first line contains an integer that you must sum with. The second line contains a double that you must sum with. The third line contains a string that you must concatenate with.

Output Format

Print the sum of both integers on the first line, the sum of both doubles (scaled to decimal place) on the second line, and then the two concatenated strings on the third line.

Sample Input

12 4.0 is the best place to learn and practice coding! Sample Output

16 8.0 HackerRank is the best place to learn and practice coding! Explanation

When we sum the integers and, we get the integer. When we sum the floating-point numbers and, we get. When we concatenate HackerRank with is the best place to learn and practice coding,. we get HackerRank is the best place to learn and practice coding!.

You will not pass this challenge if you attempt to assign the Sample Case values to your variables instead of following the instructions above and reading input from stdin.

"Why am i converting this variables to console.readline??" you're not, you are converting the value returned by Console.Readline() and you specify to convert it into an Int32 with Convert.ToInt32()

By default, the Console.Readline() method returns a string ( see the documentation ), but you wanna use the result as an int so that's why you have to convert it

The technical post webpages of this site follow the CC BY-SA 4.0 protocol. If you need to reprint, please indicate the site URL or the original address.Any question please contact:yoyou2525@163.com.

 
粤ICP备18138465号  © 2020-2024 STACKOOM.COM